Dec 25, 2006

First customer!

Ok. It's not ready yet. Hell, we don't even have an ISO image that installs everything. Uhm ... did I mention it also has bugs? You want it nonetheless? Rrrrrrighto!

Category: General
Posted by: mstauber

Today Aventurin{e} was deployed on the first customers server. Not a development box, but an productive server that hosted revenue generating sites, crucial for the existence of multiple companies.

I usually would not have done it, but the client was really in a hurry and dire straits. His old RaQ550's lease was up and he was shifting providers. He wanted Aventurin{e} on the new server, but could not afford to wait any longer. We had exactly until 31st December 2006 to get him sorted. So on Christmas (25th December) I started installing Aventurin{e} on a dedicated Hetzner DS9000 server. Given the current shape of the installer (still the "mini-1.0.iso!) it helped a lot that the server had an eRIC remote administration card. However, due to issues with Anaconda we had to ask Hetzer's support to attach an USB CD-ROM and put a CD burned from the ISO image in.

The install was a bit tricky, but in the end I got everything up and running. Soon afterwards the migration from the RaQ550 to several new BlueQuartz virtual servers on Aventurin{e} started. All in all that went pretty seamless.

During the next couple of days I was monitoring that server carefully. Would Aventurin{e} work just fine? Would it hold up to the high expectations? Would the box crash? Would the heavily modified CentOS + BlueQuartz OS-templates keep together? To be honest I had my doubts and was also a bit scared.

However, it turned out to be totally unexciting. The server continued to run without any hitches for four months. Only on the day when all the cumulated patches from the release candidate were installed we had a minor issue which was solved quickly.

Previous page: Aventurin{e} Next page: Specifications